Delay in processing email and SMS subscriptions
Incident Report for Klaviyo
Resolved
This incident has been resolved. All systems are operational.
Posted Apr 13, 2023 - 09:22 EDT
Monitoring
The issue has been identified and resolved. Event processing and associated Flow message sending as well as outbound events to integrations are back to real-time.

Engineering will continue to monitor the results.
Posted Apr 12, 2023 - 12:13 EDT
Update
We are continuing to investigate this root cause of the issue. Around 9:05 AM US Eastern, we fixed a few delays in our systems.

Email and SMS message sending, including double opt-in messages is real-time
Profiles being added to lists and segments loading is real-time
Unique coupon codes in forms is functional

The following are still impacted:
Delays in event processing and associated Flow message sending still happening
Delays in outbound events to integrations still happening

Our team is looking into the issue further and will continue to provide updates.
Posted Apr 12, 2023 - 09:44 EDT
Update
We are continuing to investigate this issue.
Posted Apr 12, 2023 - 09:12 EDT
Investigating
At 6:40 AM US Eastern, we observed a delay in processing subscription events for email and SMS subscribers. This currently causes:

Delays in Email and SMS message sending, including double opt-in messages
Delays in event processing and associated Flow message sending (e.g. Welcome Series)
Delays in profiles being added to lists and segments loading
Delays in outbound events to integrations
Delays in unique coupon codes and forms; currently sending fallback coupons and forms if enabled


Our engineering team is actively investigating the issue and will provide more updates once we have more information.
Posted Apr 12, 2023 - 08:56 EDT
This incident affected: Email Sending (Flow Email Sending) and Flow Triggering, List Subscription.