Delays in Real-Time Segmentation
Incident Report for Klaviyo
Resolved
All systems remain fully operational and we have completed all necessary repairs for segments impacted during the incident. This incident is now resolved.
Posted Nov 30, 2022 - 16:31 EST
Monitoring
Real-time segmentation has been fully restored and continues to function as expected without delays. Additionally, we have finished repairs on a large portion of segments that fell out-of-date during the incident. We will continue to monitor all systems as we make progress on repairing the remaining out-of-date segments.
Posted Nov 28, 2022 - 19:18 EST
Update
We have restored real-time segmentation updates. Newly created or updated segments should automatically stay up-to-date in real time moving forward. We are working to repair segments that may have been impacted and fallen out-of-date during this incident. Repairs will not trigger out-of-date segment-triggered Flows in order to preserve timeliness of messages.
Posted Nov 28, 2022 - 07:35 EST
Update
While we continue to make progress processing the outstanding backlog of activity updates, we expect this to continue over the course of the day. We will provide an update once real-time segmentation processing has been fully restored.
Posted Nov 27, 2022 - 11:54 EST
Update
Due to ongoing processing delays, manually created or updated segments may appear empty or incorrect if querying recent activity.

We expect all processing to catch up by mid-morning November 27 US Eastern, at which point newly created or updated segments will update with accuracy. Once caught up, all automatic updates for existing segments will also be back to real-time.
Posted Nov 26, 2022 - 20:39 EST
Update
We continue to work on restoring real-time segmentation processing. Due to delays in automatic updates, segments may remain out-of-date as we work to mitigate the impact of this incident. We will post another update here when more information becomes available on resolution timing.
Posted Nov 26, 2022 - 13:14 EST
Update
Users creating new segments, or updating the definition of existing segments, should not experience any delays in processing. However, real-time updates to existing segments remain significantly delayed.

As noted previously, due to this ongoing incident, segment-triggered Flows and segment-targeted Campaigns may send to out-of-date audiences at this time. Segment-targeted Forms are also affected. Email and SMS sending remain fully operational.
Posted Nov 26, 2022 - 03:16 EST
Update
Efforts to reduce outstanding delays were not as effective as planned, and real-time segmentation delays remain up to 4.5 hours. In addition, users creating a new segment or updating the definition of an existing segment may see up to a 2 hour delay in processing.

We are actively working to fully restore segmentation processing and mitigate outstanding delays.
Posted Nov 25, 2022 - 21:47 EST
Update
Real-time segmentation processing remains delayed. Due to this ongoing incident, segment-triggered Flows and segment-targeted Campaigns may send to out-of-date audiences. Segment-targeted Forms are also affected. Email and SMS sending are not impacted.

While there remains a maximum delay of up to 2.6 hours, delays are now rapidly reducing. We are actively working to restore real-time segmentation processing within 2 hours.
Posted Nov 25, 2022 - 18:54 EST
Update
We now are experiencing delays of up to 3 hours in real-time segmentation processing. Flows triggered by segments, as well as segment-targeted forms, continue to be impacted. We are actively working to restore real-time processing and will continue to provide updates here.
Posted Nov 25, 2022 - 15:52 EST
Identified
We are currently experiencing delays of up to 1.5 hours in real-time segmentation processing. Flows triggered by segments, as well as segment-targeted forms, may also currently be impacted. We are actively working to restore real-time processing and will continue to provide updates here.
Posted Nov 25, 2022 - 11:19 EST
This incident affected: Segmentation.