Delays in Event Processing, Flow Triggering & Segmentation
Incident Report for Klaviyo
Resolved
Event processing, flow-triggering, and real-time segmentation are all now real-time. This incident has been resolved.
Posted Jul 28, 2020 - 08:56 EDT
Monitoring
We have resolved the issue affecting event processing, flow triggering, and segmentation. As a result, we have begun processing events again. All flow-triggering and real-time segmentation is operational, but processing is delayed by roughly 3 hours for all metrics. It will take several hours to catch up. We will post updates as more information becomes available.
Posted Jul 28, 2020 - 07:49 EDT
Update
We have addressed the API and in-app experience errors. However, we are continuing to work on restoring event processing which is impacting event-triggered flows and real-time segmentation. Event processing continues to be delayed since 4:30AM ET (Eastern Time). We will provide updates here as we continue to investigate.
Posted Jul 28, 2020 - 07:32 EDT
Update
We are continuing to work on restoring event processing, flow triggering, segmentation, and the other affected components. We will provide updates here as we continue to investigate.
Posted Jul 28, 2020 - 06:36 EDT
Investigating
We are investigating an incident resulting in delays in event processing starting at 4:30AM ET (Eastern Time). Event-triggered flows and real-time segmentation are impacted. Additionally, we are currently seeing intermittent API errors and in-app experience errors. We are in the process of restoring normal operations and will continue to provide updates here.
Posted Jul 28, 2020 - 05:41 EDT
This incident affected: Klaviyo App (Klaviyo App), Email Sending (Campaign Email Sending, Flow Email Sending), and Klaviyo API, Analytics, Segmentation, Flow Triggering, Klaviyo.com.