Delays in Event Processing
Incident Report for Klaviyo
Resolved
Analytics, flow-triggering and real-time segmentation are all now real-time. This incident has been resolved.
Posted Jul 10, 2020 - 01:27 EDT
Update
Analytics, flow-triggering and real-time segmentation are all now real-time. This incident has been resolved.
Posted Jul 10, 2020 - 01:27 EDT
Update
All flow-triggering and real-time segmentation is live, but analytics are still delayed by roughly an hour for 25% of all metrics. We will continue monitoring this issue until analytics for this last 25% of metrics are real-time
Posted Jul 09, 2020 - 23:28 EDT
Update
All flow-triggering and real-time segmentation is live, but analytics are still delayed by roughly an hour for 25% of all metrics. We will continue monitoring this issue until analytics for this last 25% of metrics are real-time.
Posted Jul 09, 2020 - 23:27 EDT
Monitoring
Flow-triggering and real-time segmentation are real-time for approximately 90% of all metrics; the remaining 10% should catch up within 60-90 minutes. Analytics processing for features such as campaign & flow reporting is real-time for approximately 40% of metrics, with the remaining 60% still delayed by 1-2 hours. We will continue monitoring these systems until all outstanding delays have resolved.
Posted Jul 09, 2020 - 18:44 EDT
Update
Our event processing jobs are approximately 1.5 - 2 hours away from catching up completely. We will continue to monitor our systems' progress and will post another update when event processing is near real-time.
Posted Jul 09, 2020 - 16:31 EDT
Update
We have resolved the issue affecting a component of our system that was preventing us from streaming events and have begun processing events again. Flow-triggering, real-time segmentation and all analytics are still delayed by several hours but we are now actively catching up. It will take several more hours to catch up, we will post updates as more information becomes available.
Posted Jul 09, 2020 - 13:51 EDT
Update
We are continuing to work on this issue. We have stabilized most event processing systems, but are currently diagnosing issues with one last component of our system that is preventing us from re-enabling the flow of events into our event pipeline. We will post another update once we have cleared all issues with this system and have a clearer ETA for a full resolution of outstanding delays.
Posted Jul 09, 2020 - 12:43 EDT
Identified
We have identified an issue in our event processing pipeline which is causing delays in real-time segment updates, segment or metric-based flow triggering, and all analytics. We are actively working to reduce delays, and we will continue to provide updates here.
Posted Jul 09, 2020 - 10:50 EDT
This incident affected: Analytics, Segmentation, and Flow Triggering.