Intermittent Issues Accessing Help Center
Incident Report for Klaviyo
Resolved
This incident has been resolved. You should now be able to access Klaviyo Help Center without any disruptions.
Posted Oct 25, 2022 - 15:18 EDT
Monitoring
A fix has been implemented by our upstream provider and we are presently monitoring the results.
Posted Oct 25, 2022 - 14:31 EDT
Investigating
Starting approximately 12:55 pm EST, we started noticing intermittent disruptions when accessing the Klaviyo Help Center due to an issue with our upstream provider. Support ticket creation may be delayed as a result. Our engineering team is presently investigating the issue.
Posted Oct 25, 2022 - 13:49 EDT
This incident affected: Klaviyo Help Center.