Email Deliverability Issues
Incident Report for Klaviyo
Resolved
The deliverability issue that led to this incident has been identified and resolved.
Posted Oct 23, 2019 - 09:28 EDT
Monitoring
The issue we were experiencing has been resolved. We will continue to watch the situation to ensure deliverability issues are fully addressed.
Posted Oct 22, 2019 - 16:11 EDT
Identified
We are experiencing degradation in email deliverability at this time with non-Gmail inbox providers, which may yield elevated bounce rates. We are currently aware of the issue and actively working on resolution. We will keep this status page updated.
Posted Oct 22, 2019 - 06:43 EDT