Cloudflare incident disrupting onsite events

Incident Report for Klaviyo

Resolved

This incident has been resolved, as of 2 pm US eastern. All affected components are operational.
Posted Nov 18, 2025 - 14:06 EST

Monitoring

Fixes have been implemented for some services and we are monitoring the issues.
Posted Nov 18, 2025 - 09:34 EST

Identified

Cloudflare declared an incident around 6:30 am US Eastern causing all onsite activities, such as unsubscribe and subscribe preference pages and onsite form submissions to error out. Forms appear, but no requests or related events or subscriptions are processing. API calls are also experiencing 403s. https://www.cloudflarestatus.com/incidents/8gmgl950y3h7

We're currently investigating mitigation steps for the affected features.
Posted Nov 18, 2025 - 08:58 EST
This incident affected: Klaviyo API, List Subscription, Signup Forms, and Unsubscribe & Preference Pages.