Facebook Ads are not syncing correctly

Incident Report for Klaviyo

Resolved

The incident is now resolved. All delayed data for Facebook Integrations, which occurred between 1:00 AM and 2:00 AM, has been fully restored.
Posted Nov 02, 2025 - 12:41 EST

Monitoring

A fix has been identified and we are monitoring the results.
Posted Nov 02, 2025 - 08:13 EST

Identified

As of 1:00 AM ET (approximately one hour ago), our Facebook integration sync encountered a failure, resulting in a temporary delay in data sync. We have confirmed that no data has been lost, and the system failure is strictly impacting sync times. The root cause has been successfully identified, and our engineering team is actively working on deploying the necessary fix.
Posted Nov 02, 2025 - 02:03 EST
This incident affected: Integrations (Integrations - Other).