Flow sending delays

Incident Report for Klaviyo

Resolved

Flow message sending has fully recovered and is processing at normal speeds. Delayed messages were not lost and have since been delivered. This incident has been resolved.
Posted Sep 17, 2026 - 15:46 EDT

Monitoring

Flow message sending is recovering, and delays are continuing to clear. Some customers may still see flow messages send later than expected as remaining processing catches up. We continue to monitor closely and appreciate your patience throughout this incident.
Posted Sep 17, 2026 - 15:21 EDT

Update

We are seeing early signs of improvement and continue to work towards full recovery. Customers may still see flow messages send later than expected. We will share another update shortly.
Posted Sep 17, 2026 - 14:30 EDT

Identified

We have identified the cause of the delays affecting flow message sending and are working on a fix. Some customers may continue to see flow messages send later than expected while we resolve this. We will share another update shortly.
Posted Sep 17, 2026 - 13:31 EDT

Investigating

We are investigating reports of delays affecting flow message sending. Some customers may see flow messages send later than expected. We will share another update as soon as we have more information.
Posted Sep 17, 2026 - 13:10 EDT
This incident affected: Flows (Email Sending, Text Message Sending, WhatsApp Sending, Mobile Push Sending, Processing).