WhatsApp Disruption

Incident Report for Klaviyo

Resolved

The issue affecting WhatsApp features within Klaviyo has been resolved as of 6:45 PM US/Eastern on June 6, 2026. Our Engineering team has monitored performance and see that WhatsApp services have been restored including message sending, integration setup and template editing. This incident has been resolved.
Posted Jun 06, 2026 - 19:05 EDT

Investigating

All WhatsApp functionality is currently unavailable for customers due to an upstream provider outage (including sending, integration setup and template editing). The Engineering team is actively investigating and will share more information as soon as it becomes available.
Posted Jun 06, 2026 - 13:18 EDT
This incident affected: SMS Sending (WhatsApp).