Delays in flows processing
Incident Report for Klaviyo
Resolved
This incident has been resolved. Flows processing is no longer delayed.
Posted Oct 02, 2024 - 23:45 EDT
Identified
We have identified a root cause for this issue and are implementing a fix. However, flows processing currently is delayed by up to 90 minutes for 50% of flows volume, and we do not have an estimate for when processing will be back to real-time. We will post another update once a timeline is available.
Posted Oct 02, 2024 - 22:12 EDT
Investigating
Since 7:15 PM US Eastern Time on October 2, Klaviyo has been experiencing a delay in flows processing and sending for approximately 50% of flow volume. Affected flows are currently delayed by about 45 minutes. We are currently investigating this issue.
Posted Oct 02, 2024 - 20:34 EDT
This incident affected: Email Sending (Flow Email Sending), SMS Sending (SMS Sending - Other), and Mobile Push Sending, Flow Triggering.