Flows in-app experience & message sending outage
Incident Report for Klaviyo
Resolved
This incident has been resolved.
Posted Apr 05, 2024 - 19:59 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 05, 2024 - 19:34 EDT
Update
We have now processed the delayed flow triggers. Additionally, any delayed flow messages have been sent. Systems are processing in real-time, and we will continue to monitor.
Posted Apr 05, 2024 - 19:33 EDT
Update
We have addressed the underlying database issue and flows functionality is now available. In-app flow pages are now available, and flow message sending has resumed. Any flows that should have triggered during the outage are expected to trigger on a delay. Any delayed flow messages will be sent.
Posted Apr 05, 2024 - 19:19 EDT
Identified
We have identified a database issue affecting flows functionality, originally beginning at 6:05PM (US Eastern). This includes in-app flow pages, flow message sending, flow triggering, and any in-app reporting including flow message data. Campaign messaging and event processing is unaffected. We are working to fix the issue and will keep this page updated with further developments.
Posted Apr 05, 2024 - 18:59 EDT
Investigating
Starting at 6:20PM (US Eastern) we identified an issue impacting flows, affecting both in-app pages and flow message sending. We are investigating the issue and working to resolve the issue.
Posted Apr 05, 2024 - 18:40 EDT
This incident affected: Klaviyo App (Klaviyo App), Email Sending (Flow Email Sending), and Flow Triggering.