Missing spam events and reports from upstream provider
Incident Report for Klaviyo
Resolved
Spam complaint events from the impacted window have been repopulated. This incident is now resolved.
Posted Jun 15, 2023 - 21:28 EDT
Update
New spam complaint events triggered after June 15 at 11:50am ET are now publishing to profiles as expected. Klaviyo is continuing to work with the upstream provider to backfill spam complaint events that occurred between June 8 2pm ET and June 15 11:50am ET, and to process the respective profile suppressions.
Posted Jun 15, 2023 - 14:10 EDT
Identified
Beginning on June 8 at 2 PM US Eastern, Klaviyo stopped receiving a subset of spam complaint events from an upstream provider. This could lead to delays in processing resulting profile suppressions. Engineers are actively working with the provider to retrieve the missing events.
Posted Jun 15, 2023 - 09:15 EDT