Delays in Email Sending
Incident Report for Klaviyo
Resolved
This incident has been resolved.
Posted Jun 09, 2020 - 23:20 EDT
Monitoring
Email delays have subsided and we are currently monitoring our systems to ensure that no delays persist. We will post another update once this issue has been fully resolved.
Posted Jun 09, 2020 - 19:52 EDT
Identified
Klaviyo is currently experiencing partial delays sending emails for campaigns, flows & login pages. Delays began shortly after 6pm EST. The root cause has been identified and we are actively working to resolve delays.
Posted Jun 09, 2020 - 19:27 EDT
This incident affected: Klaviyo App (Klaviyo App) and Email Sending (Campaign Email Sending, Flow Email Sending).