Errors when creating a Klaviyo account
Incident Report for Klaviyo
Resolved
We have successfully restored sign up functionality. All Klaviyo.com visitors are able to successfully create Klaviyo accounts.
Posted Jun 16, 2023 - 16:01 EDT
Monitoring
At around 4:00 pm ET on June 15th, a small percentage of visitors of klaviyo.com started experiencing errors when attempting to create a Klaviyo account. We have identified and addressed the the issue and are monitoring to ensure full sign up functionality is restored.
Posted Jun 16, 2023 - 15:44 EDT
This incident affected: Klaviyo.com.