Campaigns List View

Incident Report for Klaviyo

Resolved

This incident has been resolved.
Posted Sep 29, 2025 - 09:27 EDT

Monitoring

We have concluded our repairs and these campaigns should now show in the campaign list view as expected. We continue to monitor closely and appreciate your patience throughout this incident.
Posted Sep 22, 2025 - 15:43 EDT

Identified

We're continuing to work through repairs for this subset of campaigns. We'll provide updates as soon as more information is available. We appreciate your patience throughout this incident.
Posted Sep 19, 2025 - 17:50 EDT

Investigating

We are currently investigating an issue where a subset of scheduled and draft campaigns may not be appearing in the campaign list view as expected. We are actively investigating. We’ll provide updates as soon as more information is available.
Posted Sep 19, 2025 - 09:38 EDT
This incident affected: Email Sending (Campaign Email Sending).