SMS Events Processing Delays

Incident Report for Klaviyo

Resolved

This incident has been resolved.
Posted Oct 29, 2025 - 15:43 EDT

Monitoring

We have mitigated the delays and we expect SMS event processing to be fully caught up within the next 20 minutes. There was no data loss as a result of this incident.
Posted Oct 29, 2025 - 15:27 EDT

Update

We are still working to restore normal processing of SMS events. A subset of customers may see delays of up to 90 minutes at this time. SMS Sending remains unaffected.
Posted Oct 29, 2025 - 15:12 EDT

Update

We want to acknowledge that downstream services (Segments and Flows) relying on the SMS events will also be impacted, until the event processing has caught up, which we expect to happen shortly.

We'll continue to provide updates as they are available.
Posted Oct 29, 2025 - 14:27 EDT

Identified

Starting at 1:00 PM US/Eastern, we began experiencing delays of up to 40 minutes for SMS events processing.

SMS Sending is not impacted.

We have identified the issue and are in the process of reverting a change to restore normal processing. We'll provide updates as soon as more information is available.
Posted Oct 29, 2025 - 14:16 EDT
This incident affected: Analytics, Segmentation, and Flow Triggering.