Klaviyo Helpdesk, Customer Hub, and Customer Agent services Outage

Incident Report for Klaviyo

Resolved

This incident has been resolved.
Posted Nov 28, 2025 - 17:05 EST

Monitoring

Access to these services (Customer Hub, Helpdesk, and Customer Agent) remains stable. We are continuing to closely monitor these systems.
Posted Nov 28, 2025 - 16:11 EST

Identified

Starting at 3:40pm (US Eastern), we have restored access to these services (Customer Hub, Helpdesk, and Customer Agent). We continue to closely monitor these systems.
Posted Nov 28, 2025 - 15:46 EST

Investigating

Starting at 3:00pm (US Eastern), Klaviyo Helpdesk, Customer Hub, and the onsite web chat functionality of Customer Agent are unavailable. Our team is investigating the issue and will update with progress as soon as possible.
Posted Nov 28, 2025 - 15:27 EST
This incident affected: K:Service (Customer Agent, Customer Hub, Helpdesk).