Delays in Event Processing, Flow Triggering & Segmentation
Incident Report for Klaviyo
Resolved
All outstanding events have been processed and this incident is now fully resolved.
Posted Sep 16, 2019 - 12:19 EDT
Update
Event processing, segmentation, and email sending are all operating in real-time. We are currently working to process all remaining delayed API events from the incident, and expect all outstanding events to be processed within 1-2 hours.
Posted Sep 16, 2019 - 08:13 EDT
Monitoring
A solution has been deployed and all events are now processing. Flow triggering and real-time segmentation continue to be delayed as we process delayed events. Metrics and campaign analytics will also be inaccurate as we catch up. We expect all analytics to be real-time within 2-4 hours, and will continue to post updates as they come in.
Posted Sep 16, 2019 - 02:07 EDT
Update
We are continuing to work on a fix for this issue, and will provide further updates shortly.
Posted Sep 15, 2019 - 23:00 EDT
Update
We're actively working to resolve this issue. Event processing, flow triggering, and real-time segmentation continue to be delayed up to 2-3 hours for some companies. We will continue to provide updates here.
Posted Sep 15, 2019 - 19:22 EDT
Identified
We have identified the underlying issue affecting a subset of customers and are working on a resolution. Event processing, flow triggering, and real-time segmentation continue to be delayed up to 2-3 hours. We are actively working on restoring full operations and we will provide another update within the next hour.
Posted Sep 15, 2019 - 18:19 EDT
Investigating
We are investigating an incident resulting in up to a 2-3 hour delay in event processing, flow triggering, and real-time segmentation updates. We are in the process of restoring normal operations and will provide an update within 30 minutes.
Posted Sep 15, 2019 - 17:56 EDT
This incident affected: Email Sending (Flow Email Sending) and Analytics, Segmentation.