Intermittent Flow Triggering & Real-Time Segmentation Disruption
Incident Report for Klaviyo
Resolved
This incident has been resolved.
Posted Jan 30, 2020 - 19:19 EST
Monitoring
We are no longer seeing intermittent escalated delays in event processing, real-time segmentation & flow triggering. We are continuing to monitor all systems.
Posted Jan 29, 2020 - 18:30 EST
Update
We continue to actively manage intermittent event processing delays to mitigate the impact on real-time segmentation & metric-triggered flows. Most customers should see minimal disruption. We are working to fix the root-cause of this incident as a top priority and will continue to provide periodic updates as we work towards full resolution.
Posted Jan 27, 2020 - 14:14 EST
Update
While we continue to actively manage intermittent increased event processing delays, some customers may continue to see elevated delays in Flow Triggering for certain metric-triggered flows.
Posted Jan 24, 2020 - 19:24 EST
Identified
Due to intermittent delay spikes in our event processing pipeline, some customers may see between 30-90 minute delays in real-time segment updates & delays in the triggering of certain metric-triggered Flows. We are actively working to reduce delays, and we will continue to provide updates here.
Posted Jan 24, 2020 - 15:06 EST
This incident affected: Segmentation and Flow Triggering.