Intermittent Application Page Load Slowness
Incident Report for Klaviyo
Resolved
We are no longer observing elevated instances of application slowness. This incident is now resolved.
Posted Feb 15, 2022 - 19:30 EST
Monitoring
We have taken measures to mitigate impact to the Klaviyo app resulting from the affected upstream provider. We are monitoring the results of this change, and will continue to provide updates here.
Posted Feb 15, 2022 - 18:22 EST
Update
We have taken measures to mitigate impact to the Klaviyo app resulting from the affected upstream provider. We are monitoring the results of this change, and will continue to provide updates here.
Posted Feb 15, 2022 - 18:22 EST
Investigating
We are experiencing intermittent cases of slowness across the Klaviyo app due to an issue with an upstream content delivery provider. The impact appears to be isolated to users located on the West Coast (USA). We will provide updates here as we have more information.
Posted Feb 15, 2022 - 17:18 EST
This incident affected: Klaviyo App (Klaviyo App).