Delay in Analytics Processing

Incident Report for Klaviyo

Resolved

As of 4:09 pm Eastern Time on June 4th, all delayed analytics have been processed and new analytics are processing in real time. This incident is now resolved.
Posted Jun 04, 2025 - 16:28 EDT

Monitoring

Starting 1:45 pm Eastern Time on June 4th, the infrastructure that processes analytics began experiencing delays. As a result, campaign, flow and dashboard reports may be out-of-date by up to about 2 hours. Event-triggered flows and segments dependent on events are not impacted. Events are also populating into profile activity logs normally.

We are actively resolving this incident and expect to have reports up-to-date within an hour.
Posted Jun 04, 2025 - 15:50 EDT
This incident affected: Analytics.