Delays in real-time segmentation

Incident Report for Klaviyo

Resolved

Profile property updates are now being reflected in real-time segments at normal speed. Any profile property changes made during the incident window have been reflected in segment membership as expected, and no action is required on your part. This incident has been resolved.
Posted Aug 19, 2026 - 14:38 EDT

Monitoring

A fix has been deployed and system performance is improving. Recent profile property updates are now being reflected in real-time segments more quickly, and the delay has improved to approximately 2.5 hours. Changes to profiles may still take slightly longer than usual to update segment membership as the system continues to catch up. Email and SMS sending and other core functions remain unaffected. We continue to monitor closely and appreciate your patience throughout this incident.
Posted Aug 19, 2026 - 14:13 EDT

Identified

We are currently experiencing delays of up to approximately 3 hours in how quickly recent profile property updates are reflected in real-time segments. This means changes to profiles may take longer than usual to update segment membership, which can affect segment-based targeting. Email and SMS sending and other core functions are operating normally. We are actively working to resolve this and will share another update as soon as we have more information.
Posted Aug 19, 2026 - 13:15 EDT
This incident affected: Audience (Segments, Profiles).