Delay in Analytics Processing for 12.5% of Metrics
Incident Report for Klaviyo
Resolved
This incident has been resolved.
Posted Nov 15, 2020 - 18:26 EST
Update
All analytics are now real-time. A very small percentage of metrics experienced overcounting as a result of this incident. Once these analytics have been will be repaired, we will resolve this incident.
Posted Nov 14, 2020 - 00:41 EST
Monitoring
All analytics are now real-time. A very small percentage of metrics experienced overcounting as a result of this incident. Once these analytics have been will be repaired, we will resolve this incident.
Posted Nov 14, 2020 - 00:40 EST
Update
The 12.5% of metrics impacted by the analytics job that failed last night are now approximately 1 hour from real-time.

However, we have encountered an issue for a separate 12.5% of metrics, and we are in the process of deploying a fix. This may be causing campaign, flow, and dashboard reports to appear outdated for these metrics. Once deployed, it will take several hours for these metrics to catch back up to real-time.

We will post further updates once we have a better estimate for when we expect analytics impacted by the latter issue are caught up.
Posted Nov 13, 2020 - 16:03 EST
Update
We have fixed the underlying issue causing analytics delays and are in the process of catching up. We expect analytics for impacted metrics to be caught up within the next 4-5 hours. We will post further updates once we are closer to real-time.
Posted Nov 13, 2020 - 12:00 EST
Update
We have determined the root cause of the delays we are experiencing but expect analytics processing delays to persist until we can successfully deploy a fix. Most metrics are delayed at least 4-5 hours, with some metrics delayed more. We are continuing to work on deploying a fix, and will post another update once it has been deployed and have better estimate for when we expect to be caught up.
Posted Nov 13, 2020 - 01:10 EST
Identified
Our analytics processing infrastructure is running 3-4 hours behind for approximately 12% of all metrics, which may be causing campaign, flow, and dashboard reports to appear outdated for affected metrics. No data has been lost, and flow-triggering, real-time segmentation and campaign sending are not impacted. We will provide further updates once we have better clarity on time to resolution.
Posted Nov 12, 2020 - 17:34 EST
This incident affected: Analytics.