Delay in SMS Sending

Incident Report for Klaviyo

Resolved

This incident has been resolved, and all messages impacted by the delays have been delivered.
Posted Mar 17, 2025 - 21:49 EDT

Monitoring

We have resolved the underlying issue causing the delays and we expect to be back to real-time SMS sending within 15 minutes. Any messages impacted by the delays will be delivered.
Posted Mar 17, 2025 - 21:35 EDT

Investigating

We are currently experiencing delays of up to 3 hours for a subset of SMS sending. Impacted SMS sends include flows, keyword responses, conversations, and preview messages. SMS campaign sending is not impacted. We are actively working to restore real-time SMS sending and will continue to provide updates here.
Posted Mar 17, 2025 - 21:05 EDT
This incident affected: SMS Sending (SMS Sending - Toll Free Number SMS, SMS Sending - Toll Free Number MMS, SMS Sending - Short Code SMS, SMS Sending - Short Code MMS).