Campaign sending has been restored and the backlog of delayed campaigns has completed sending. This incident has been resolved.
Posted Jun 08, 2026 - 20:49 EDT
Monitoring
We have deployed a fix and campaign sending is recovering. We are processing the backlog of delayed campaigns and expect to deliver them shortly. We continue to monitor closely and appreciate your patience throughout this incident.
Posted Jun 08, 2026 - 19:54 EDT
Update
We are continuing to work through the fix for this issue. We are working to resolve this as quickly as possible and will share another update shortly.
Posted Jun 08, 2026 - 19:20 EDT
Identified
We have identified the root cause and are working on a fix. We will share another update shortly.
Posted Jun 08, 2026 - 17:19 EDT
Investigating
Some customers may be experiencing delays with campaign sending, where sends are currently stuck in processing. We are investigating the issue and will provide an update as soon as we have more information.
Posted Jun 08, 2026 - 17:10 EDT
This incident affected: Email Sending (Campaign Email Sending) and SMS Sending (SMS Sending - Toll Free Number SMS, SMS Sending - Toll Free Number MMS, SMS Sending - Short Code SMS, SMS Sending - Short Code MMS).