Intermittent Application Page Load Issues

Incident Report for Klaviyo

Resolved

This incident has been resolved.
Posted Dec 04, 2019 - 23:59 EST

Monitoring

We have resolved the disruption impacting app availability and Klaviyo Form subscriptions. We will continue to monitor all systems.
Posted Dec 04, 2019 - 22:57 EST

Update

We are aware of continued intermittent slowness and page load issues across the Klaviyo platform. Subscribers may also experience errors when submitting Klaviyo Forms. We are actively working on this issue and will continue to provide updates here.
Posted Dec 04, 2019 - 20:30 EST

Identified

We are currently investigating reports of page load issues across the Klaviyo application. We will provide an update shortly.
Posted Dec 04, 2019 - 19:50 EST
This incident affected: Klaviyo App (Klaviyo App) and Signup Forms.