Delays in Event Processing

Incident Report for Klaviyo

Resolved

Event processing has been fully restored. This incident is now resolved.
Posted Jul 08, 2025 - 15:50 EDT

Monitoring

We have mitigated the delays and event-processing has been restored to real-time. There was no data loss as a result of this incident. We’re continuing to monitor and will post another update once we have fully cleared any backlog of processing data.
Posted Jul 08, 2025 - 15:44 EDT

Investigating

We are currently experiencing delays in event processing. Customers may see delays in event data syncing, event-triggered flows sending, and real-time segmentation.

We are in the process of restoring normal operations and will continue to provide updates here.
Posted Jul 08, 2025 - 15:20 EDT
This incident affected: Analytics, Segmentation, and Flow Triggering.