Delay in Analytics Processing for 12.5% of Metrics
Incident Report for Klaviyo
Resolved
All analytics are now real-time. This incident has been resolved.
Posted Sep 21, 2021 - 17:31 EDT
Update
Analytics are still approximately 3 hours behind real-time for impacted metrics. We will provide another update once all analytics are real-time.
Posted Sep 21, 2021 - 10:09 EDT
Update
Analytics are approximately 8-9 hours behind real-time for impacted metrics. We expect analytics for impacted metrics to catch up to real-time by end-of-day today, and will provide another update once all analytics are real-time.
Posted Sep 20, 2021 - 10:29 EDT
Update
Analytics for impacted metrics are now in the process of catching up. Due to the size of the event backlog we do not yet have an estimate for when analytics will return to real-time, but we expect it will take at least the majority of the day today, if not longer. We will provide another update once we have a better estimate as to when we expect impacted metrics to catch-up.
Posted Sep 18, 2021 - 07:53 EDT
Update
The underlying issue causing analytics delays has been fixed, and the single job processing events for the impacted metrics has been split into two separate jobs in order to better handle the required workload moving forward. However, both new jobs will be in the process of bootstrapping for several more hours.

At this time, analytics for the 12.5% of metrics impacted are still delayed, and campaign, flow, and dashboard reports may appear unpopulated or outdated as of 12:00 AM (US Eastern Time) on Sept. 16. We will provide further updates once we are able to begin catching up analytics for all impacted metrics.
Posted Sep 17, 2021 - 16:32 EDT
Identified
We have identified an issue impacting roughly 12.5% of all Klaviyo metrics. Campaign, flow, and dashboard reports may appear unpopulated or outdated since 12:00 AM (US Eastern Time) on Sept. 16 for impacted metrics. Campaign sending, flow-triggering and real-time segmentation are not impacted, and no data is lost. We will provide updates as metrics catch up.
Posted Sep 16, 2021 - 11:51 EDT
This incident affected: Analytics.