Elevated Hard Bounce Rates on Apple Inboxes
Incident Report for Klaviyo
Resolved
All suppressions have been removed for profiles that incurred hard bounces due to this incident. This incident is now resolved.
Posted Apr 28, 2021 - 09:05 EDT
Update
Removal of suppressions for impacted profiles is continuing. We will confirm when this has been completed.
Posted Apr 27, 2021 - 14:59 EDT
Monitoring
We can confirm that we are no longer observing elevated hard bounces for Apple inboxes.

We will provide an update when suppressions are removed from impacted hard-bounced profiles.
Posted Apr 26, 2021 - 12:56 EDT
Investigating
Beginning at 7:13 AM Eastern, we began observing elevated hard bounce rates from Apple inboxes (icloud.com, mac.com, me.com). This is reflected on Apple's status page as well: https://www.apple.com/support/systemstatus/

In order to avoid incurring unwarranted suppressions due to false hard bounces, we recommend excluding recipients with Apple inboxes from your campaigns. We will update this page with more information as it becomes available.
Posted Apr 26, 2021 - 09:50 EDT
This incident affected: Email Sending (Email Deliverability).