Email events missing from customer accounts
Incident Report for Klaviyo
Resolved
As of 9 pm EST on February 11, 2023, all Received Email events have been successfully backfilled. Deliverability rates are updated and accurate. There are no further delays in event processing, and this incident is resolved.
Posted Feb 12, 2023 - 10:21 EST
Update
Received Email events are continuing to backfill for accounts and you should see your deliverability rates increasing. We expect to be fully caught up by mid-morning EST on February 11, 2023.
Posted Feb 10, 2023 - 12:56 EST
Update
We have begun backfilling the missed email events and expect to be fully caught up early tomorrow. Upon further investigation, only the Received Email metric was impacted. All other email related events remain unaffected. We will post an update once the backfill is complete.
Posted Feb 09, 2023 - 17:25 EST
Identified
On February 8, 2023 at around 4 pm EST, we noticed email related events were not recorded in customer accounts. This has impacted deliverability reporting and rates for campaigns. Most emails have been delivered, and we are working to update our reporting.
Posted Feb 09, 2023 - 15:03 EST