Profile Delete and Merge Issue
Incident Report for Klaviyo
Resolved
This incident is resolved. All profile delete and merge functionality has been restored. All deletes and merges paused during this time have been processed.
Posted Aug 22, 2024 - 13:19 EDT
Identified
Starting at 9:00 AM US Eastern Time, Klaviyo began maintenance resulting in the pause of profile deletion and merging functionality. We are actively working to restore profile delete and merge functionality and will continue to provide updates here.
Posted Aug 22, 2024 - 11:57 EDT
This incident affected: Klaviyo.com.