Delays in event-based flow processing

Incident Report for Klaviyo

Resolved

This is now resolved, triggering is back to real-time.
Posted Aug 12, 2025 - 13:14 EDT

Monitoring

Triggering of event-based flows is now back to real-time. We're continuing to monitor and will provide an additional confirmation of full recovery.
Posted Aug 12, 2025 - 13:05 EDT

Investigating

We are currently investigating delays in the triggering of event-based flows, which began around 08/12/2025 at 11:45 US/Eastern.

Our team is actively working to resolve the issue. Further updates will be provided as soon as new information is available.
Posted Aug 12, 2025 - 12:39 EDT
This incident affected: Email Sending (Flow Email Sending).