Sending delays for event-triggered flows

Incident Report for Klaviyo

Resolved

The backlog of delayed event-triggered flows has been fully processed and all systems are now operating normally. We apologize for the disruption this caused. This incident has been resolved.
Posted Sep 14, 2026 - 21:51 EDT

Monitoring

Event-triggered flow processing is recovering, and our systems are now working through the backlog of delayed messages. Delayed messages will continue to send automatically as the backlog clears. A fix has been deployed and system performance is improving. We continue to monitor closely and appreciate your patience throughout this incident.
Posted Sep 14, 2026 - 21:07 EDT

Update

Our team is continuing to implement a fix to mitigate the delays affecting event-triggered flows. Delays to affected flows remain at approximately 2 hours. We are working to resolve this as quickly as possible and will share another update shortly.
Posted Sep 14, 2026 - 20:25 EDT

Identified

We have identified the cause of the delays affecting event-triggered flows. Affected flows may see delays of approximately 2 hours. Our team is now working on a fix to restore processing back to normal speed. We are working to resolve this as quickly as possible and will share another update shortly.
Posted Sep 14, 2026 - 19:18 EDT

Update

We are continuing to investigate the delays affecting event-triggered flows. Some customers may see these flows send with delays of approximately 90 minutes while we work to restore normal performance. We will provide another update shortly.
Posted Sep 14, 2026 - 18:22 EDT

Investigating

We are currently investigating a delay in the sending of event-triggered flows. Some customers may see these flows send later than expected. Scheduled campaigns and other areas of Klaviyo are not affected. We will share another update as soon as we have more information.
Posted Sep 14, 2026 - 17:30 EDT
This incident affected: Flows (Email Sending, Text Message Sending, WhatsApp Sending, Mobile Push Sending, Processing).