Klaviyo log-in issue

Incident Report for Klaviyo

Resolved

This incident has been resolved.
Posted Mar 06, 2025 - 16:17 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 06, 2025 - 11:49 EST

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 06, 2025 - 11:28 EST

Investigating

At 10:09am US Eastern we identified an issue causing delays to log-in, including via SMS MFA. We are working to resolve the issue, and in the meantime, users can log-in via the one-time password code if available. Please reach out to support if you cannot access your account.
Posted Mar 06, 2025 - 10:37 EST
This incident affected: Klaviyo App (Klaviyo App).