Processing failures affecting multiple services
Incident Report for Klaviyo
Resolved
We have concluded monitoring of this incident. We have confirmed that services continue to function as expected.
Posted Oct 26, 2023 - 22:00 EDT
Monitoring
As of 9:12 am Eastern Time, the issue causing impacts to several services has been resolved.

We have confirmed that the following services are functioning as expected:
-requests to subscribe and unsubscribe API endpoints
-subscriptions via forms
-form publishes and form metrics
-editing and creating segments
-email campaign messages

New real-time segment updates are processing at normal speeds. Real-time segment updates from during the incident period have resumed processing and may take several hours to complete.
Posted Oct 25, 2023 - 09:34 EDT
Investigating
At around 7:55 AM Eastern Time an internal system underwent scheduled maintenance resulting in unexpected impacts to several product areas. Our engineering team is working to restore the system.

The following services are currently impacted:
-requests to subscribe and unsubscribe API endpoints
-subscriptions via forms
-a small portion of form publishes and form metrics
-editing and creating segments
-real-time segment updates are delayed by 40 minutes
-some email campaign messages are failing to deliver

We will keep this incident up to date as we work to restore services.
Posted Oct 25, 2023 - 08:55 EDT
This incident affected: Email Sending (Campaign Email Sending) and Klaviyo API, Segmentation, Signup Forms.