Delay in Real-Time Event Processing

Incident Report for Klaviyo

Resolved

This incident has been resolved.
Posted Sep 19, 2025 - 16:24 EDT

Monitoring

Event processing has been restored to real-time. There was no data loss as a result of this incident. We’re continuing to monitor and will post another update once we have fully cleared any backlog of processing data.
Posted Sep 19, 2025 - 14:42 EDT

Update

A fix has been implemented and we are monitoring the results. We expect real time event processing to be fully restored within 1 hour.
Posted Sep 19, 2025 - 13:07 EDT

Identified

At around 7 AM Eastern time, we began experiencing delays in real-time event processing. Events may be out of date by up to 3 hours. Flows, Segments, Profiles, Reporting, as well as segment-targeted forms, may be impacted. We are actively working to restore real-time processing and will continue to provide updates here.
Posted Sep 19, 2025 - 10:38 EDT
This incident affected: Analytics, Segmentation, and Profiles.