Partial API Event Processing Outage & Increased Latency
Incident Report for Klaviyo
Resolved
Average latency on the Track API has returned to normal levels, and we have not observed any subsequent event loss. This incident is now resolved.
Posted Jun 24, 2022 - 14:55 EDT
Monitoring
Between 12:00 PM - 12:45 PM US/Eastern on Friday, June 24, Klaviyo API servers returned an elevated volume of 500 errors. This resulted in a partial loss of API calls during this window from Klaviyo's onsite JavaScript, as well as custom API events to Klaviyo's Track APIs during this period. Unfortunately, due to the nature of this outage, these lost events cannot be recovered or replayed.

The change that caused this outage has been reverted, and there has been no subsequent event loss as of 12:45 PM US/Eastern. We will continue to monitor error rates moving forward.

Additionally, we have observed elevated API response times since 12:00 PM US/Eastern, but these have been trending downward since the event outage. We will leave this incident open until response times have returned to expected levels.
Posted Jun 24, 2022 - 14:28 EDT
This incident affected: Klaviyo API.