Delays to SMS campaigns and other campaigns features
Incident Report for Klaviyo
Resolved
This incident has been resolved.
Posted Mar 25, 2024 - 19:05 EDT
Monitoring
A fix has been implemented for the issue and we are monitoring the results.
Posted Mar 25, 2024 - 15:49 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 25, 2024 - 15:48 EDT
Investigating
Starting at approximately 2:10 PM EST, Klaviyo started experiencing delays in page loading impacting multiple pages which can include campaigns creation, reviewing campaigns, and campaigns reporting and analytics for email, push, and SMS. Scheduled campaigns may also be experiencing some delays.

Our Engineering Team is actively working to identify the root cause and quickly address the issue. We apologize for the disruption and aim to have this issue resolved as soon as possible.
Posted Mar 25, 2024 - 15:14 EDT
This incident affected: Email Sending (Campaign Email Sending), SMS Sending (SMS Sending - Toll Free Number SMS, SMS Sending - Toll Free Number MMS, SMS Sending - Short Code SMS, SMS Sending - Short Code MMS, SMS Sending - Other, SMS Deliverability), and Mobile Push Sending, Analytics.