Issues with Site and API Accessibility
Incident Report for Klaviyo
Resolved
This incident has been resolved.
Posted Jun 05, 2024 - 15:38 EDT
Monitoring
Starting at 1 PM (US Eastern Time), we observed recovery in site and API accessibility. Site and API availability are back to normal. Our Engineering Team continues to monitor the situation.

Data from API requests that received a 502 error from 12:35 PM to 1 PM (US Eastern Time) would have been lost.
Posted Jun 05, 2024 - 13:34 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 05, 2024 - 13:03 EDT
Investigating
We are seeing a disruption in our site and API accessibility starting at 12:35 PM (US Eastern Time) on Wed, Jun 5, 2024. This is impacting users’ ability to access klaviyo.com as well as API requests. We are investigating the issue and working to mitigate the issue.
Posted Jun 05, 2024 - 12:54 EDT
This incident affected: Klaviyo App (Klaviyo App) and Klaviyo API, Klaviyo.com.