Event-triggered flow delays

Incident Report for Klaviyo

Resolved

This incident has been resolved.
Posted Sep 16, 2025 - 17:21 EDT

Monitoring

A fix has been deployed and system performance is improving. We continue to monitor closely and appreciate your patience throughout this incident.
Posted Sep 16, 2025 - 17:17 EDT

Identified

Starting 3:50pm US/Eastern on 9/16/25, we began observing delays in event-triggered flows. Users may see delays of up to 60 minutes. We're currently working on a fix. We’ll provide updates as soon as more information is available.
Posted Sep 16, 2025 - 17:05 EDT
This incident affected: Email Sending (Flow Email Sending).