Partial API Outage
Incident Report for Klaviyo
Resolved
This incident has been resolved.
Posted Sep 21, 2022 - 21:08 EDT
Update
For Shopify and Recharge integrations, all impacted events have been recovered or replayed. However, any direct API calls cannot be recovered or replayed and will need to be retried. For customers with a Segment integration, please reach out to Segment’s support team at friends@segment.com to see if your data is eligible for a manually triggered replay. We will continue monitoring all activity.
Posted Sep 21, 2022 - 18:23 EDT
Update
For Shopify and Recharge integrations, we are continuing to work with our partners to replay any dropped data as needed. However, any direct API calls cannot be recovered or replayed and will need to be retried. For customers with a Segment integration, please reach out to Segment’s support team at friends@segment.com to see if your data is eligible for a manually triggered replay.
Posted Sep 21, 2022 - 17:25 EDT
Monitoring
Between 1:40 PM - 2:28 PM US/Eastern on September 21, Klaviyo API servers returned an elevated volume of 403 errors. This resulted in potential data loss from failed API calls during this window for Shopify, Recharge, and Segment integrations, as well as any direct API calls. For integrations, we will work with our partners to replay any dropped data as needed. However, any direct API calls cannot be recovered or replayed and will need to be retried.

The change that caused this outage has been reverted, and there has been no subsequent event loss as of 2:29 PM US/Eastern. We will continue to monitor error rates moving forward.
Posted Sep 21, 2022 - 15:08 EDT
This incident affected: Klaviyo API.