Failures in processing email events
Incident Report for Klaviyo
Resolved
The remaining 3% of events continued to restore overnight, and we completed restoration today as of 11 AM US Eastern.

This incident is now resolved.
Posted May 12, 2023 - 14:11 EDT
Update
We have successfully restored events for 97% of affected accounts for the impact window between 11:45 AM and 4:00 PM US Eastern on May 8th.

We are continuing to work towards restoring events for the remaining 3% of accounts. We will confirm here when remaining accounts have had events fully restored.
Posted May 11, 2023 - 15:23 EDT
Update
We are continuing to work towards restoring events for emails sent during the incident, between 11:45 AM and 4:00 PM US Eastern on May 8th. While we are delayed, we are still working towards restoring impacted events.
Posted May 10, 2023 - 10:31 EDT
Update
We are continuing to work towards restoring events for emails sent during the incident, between 11:45 AM and 4:00 PM US Eastern on May 8th. We expect to begin restoring events later today, May 9th.
Posted May 09, 2023 - 11:10 EDT
Identified
At around 4:00 PM EST, we identified and resolved the issue causing the failure of some email events. Events for emails sent after 4PM are now processing as expected into Klaviyo analytics and profiles. We are still identifying a resolution for emails sent during the incident, between 11:45 AM and 4:00 PM EST.
Posted May 08, 2023 - 16:05 EDT
Update
We are continuing to investigate this issue.
Posted May 08, 2023 - 15:47 EDT
Investigating
Some events tied to emails sent after 11:45 AM EST have failed to process into Klaviyo. These events (ex. link clicks) have failed to publish in profiles, metrics or analytics pages. We are currently investigating this issue and will keep this status up-to-date with latest findings and resolutions.
Posted May 08, 2023 - 15:46 EDT
This incident affected: Analytics.