Delayed flow processing and message sending

Incident Report for Klaviyo

Resolved

This incident has been resolved.
Posted May 23, 2025 - 16:25 EDT

Monitoring

At approximately 2:55 PM (US Eastern), we have addressed the underlying issue and that delayed flow functionality. Flow messages sending is now real time and any flows that should have triggered are expected to trigger on a delay. Any delayed flow messages will be sent.
Posted May 23, 2025 - 15:31 EDT

Identified

We have identified a database issue affecting flow functionality, originally beginning at 11:00 AM (US Eastern). This includes flow message sending, flow triggering, and flow processing. Campaign messaging and event processing is unaffected. We are working to fix the issue and will keep this page updated with further developments.
Posted May 23, 2025 - 12:38 EDT

Investigating

Starting at approximately 11 AM (US Eastern) we identified an issue impacting flows affecting both flow evaluations and flow message sending. We are investigating the issue and will continue to post updates here.
Posted May 23, 2025 - 12:22 EDT
This incident affected: Email Sending (Flow Email Sending) and Flow Triggering.