Processing delays

Incident Report for Klaviyo

Resolved

Segmentation continues to process in real-time and is fully recovered. We determined the delays resulted from instability with an upstream infrastructure provider (AWS). This incident is now resolved.
Posted May 08, 2026 - 15:05 EDT

Monitoring

Segmentation has been restored to real-time processing, and campaign and forms analytics have now recovered. This was a reporting UI display issue only, no data was lost. Our engineering team continues to monitor closely until our upstream service provider has confirmed full recovery.
Posted May 08, 2026 - 12:59 EDT

Update

Segmentation has been restored to realtime processing. Our engineering team continues to restore the remaining affected analytics. We will continue to provide updates as real-time analytics functionality resumes.
Posted May 08, 2026 - 03:08 EDT

Update

A subset of customers are currently experiencing segmentation processing delays of approximately 1.5 hours and may find that analytics data is not fully up to date. Access to reporting pages has been restored and our engineering team is actively working to bring segmentation and analytics back to real time. We'll provide updates as soon as more information is available.
Posted May 07, 2026 - 23:46 EDT

Identified

Our engineering team continues to investigate areas affected by an upstream service provider. Customers may experience processing delays for segmentation and analytics, and loading issues with reporting pages.

For campaigns, sends may not reach the most up-to-date audience due to segmentation delays. Segment-triggered flows may also fail to trigger correctly as profiles may not be added to or removed from segments as expected. We'll provide updates as soon as more information is available.
Posted May 07, 2026 - 22:22 EDT

Investigating

We are currently investigating an issue affecting analytics and reporting, flows, campaigns, and segmentation. This issue appears to be related to a disruption with an upstream service provider. Customers may experience errors or be unable to load flows and campaigns pages, see delays in real-time segmentation updates, and find analytics data temporarily unavailable.

Our team is actively working to resolve this. We'll provide updates as soon as more information is available.
Posted May 07, 2026 - 21:32 EDT
This incident affected: Klaviyo API, Analytics, Segmentation, and Flow Triggering.