Errors when attempting to select templates for campaigns

Incident Report for Klaviyo

Resolved

Customers should no longer see any errors when selecting a template while creating or editing a campaign. This incident has been resolved.
Posted Jun 10, 2026 - 15:46 EDT

Monitoring

A fix has been deployed and system performance is improving. Customers should start to be able to successfully select a template. We continue to monitor closely and appreciate your patience throughout this incident.
Posted Jun 10, 2026 - 15:23 EDT

Identified

We have identified the root cause and are working on a fix. We will share another update shortly.
Posted Jun 10, 2026 - 15:02 EDT

Investigating

Customers may be experiencing an error when selecting a template while creating or editing a campaign. Our team is actively investigating and will share another update as soon as we have more information.
Posted Jun 10, 2026 - 14:47 EDT
This incident affected: Email Sending (Email Content).