Delay in Analytics Processing
Incident Report for Klaviyo
Resolved
All analytics affecting the subset of unique counts impacted by this incident have been repaired, and this incident has been resolved.
Posted Oct 14, 2020 - 12:48 EDT
Update
All analytics from the September 16 4pm to 9pm time window have been replayed. As a result, all instances of under-counted events for campaigns or flows during this time window have been fixed.

We are still replaying analytics affecting a subset of unique counts, and we anticipate the repair for these metrics to complete within the next week. Until then, unique counts for affected metrics could be over-counted. We will post an update once the full analytics replay has been completed.
Posted Sep 22, 2020 - 17:31 EDT
Monitoring
All analytics are now real-time. Some analytics metrics may appear inaccurate such as unique counts and events received on September 16 from 4pm to 9pm ET (Eastern Time). These analytics will be replayed over the next several days. We will post another update once this analytics replay is complete.
Posted Sep 17, 2020 - 05:29 EDT
Update
A majority of analytics metrics are now real-time, with the remaining 25% subset of all metrics expected to catch up to real-time within the next 2 hours. Once the processing is in realtime, some analytics metrics may appear inaccurate such as unique counts and events received from 4PM to 9PM ET (Eastern Time). These analytics will be replayed over the next several days.

We will continue to monitor our systems’ progress and will post another update when all analytics metrics are near real-time.
Posted Sep 17, 2020 - 03:43 EDT
Update
We have resolved the underlying issue, and we have begun to process the backlog of analytic data since the start of the incident. Reporting is still delayed, and we anticipate it may take several hours to catch up. We will post an update as more information becomes available.
Posted Sep 16, 2020 - 22:01 EDT
Update
We are working to resolve this issue, but we currently do not have an estimated timeframe for resolution. We will provide the next update once we have an estimate for when analytics will start catching up.
Posted Sep 16, 2020 - 18:21 EDT
Identified
Starting at 4PM (Eastern Time), our analytics processing infrastructure began experiencing delays which are causing campaign, flow, and dashboard reports to appear outdated. These reports will be outdated for the next several hours.

No flow or campaign sending is affected, and no data has been lost. We will provide further updates once we have a better estimate for when all analytics will be caught up.
Posted Sep 16, 2020 - 17:13 EDT
This incident affected: Analytics.