Delays in email & mobile push event processing

Incident Report for Klaviyo

Resolved

Email message events are now processing in real-time, and the team is replaying any dropped events.
Posted Jun 28, 2025 - 11:58 EDT

Identified

We have addressed the underlying issue and have begun processing email message events. We expect to process all of the delayed events with no data loss.

The team determined that push message events were not impacted.
Posted Jun 28, 2025 - 10:46 EDT

Investigating

We are currently investigating a delay in event processing for email & mobile push related events such as delivered, open, and click events. The delay began at 2:00AM (US Eastern). Any email or push message reporting and segments based on email or push events will be outdated. Message sending is not impacted. We are working to resolve this delay in event processing.
Posted Jun 28, 2025 - 09:50 EDT
This incident affected: Analytics and Segmentation.