Delays in Message Sending, Message Scheduling, Event Processing, and Segmentation
Incident Report for Klaviyo
Resolved
Segmentation is now real-time and all affected components are operational. This incident is resolved.
Posted Apr 11, 2023 - 15:57 EDT
Monitoring
Flow triggering, subscription processing, and event processing have all recovered to real-time. We expect segmentation to be real time within approximately one hour. We will continue providing updates here.
Posted Apr 11, 2023 - 15:15 EDT
Identified
We are observing scheduling and sending recovery as of 2:40 PM US Eastern, and are working to remediate other impacted areas. We will continue posting updates here as other components recover.
Posted Apr 11, 2023 - 14:48 EDT
Investigating
Beginning at 1:45 PM US Eastern, we began observing degraded functionality which led to the following issues:

Delay in Processing Subscription Events
Delay in Schedule Forms being published
Delays in Email and SMS message sending, including double opt-in messages
Delays in event processing and associated Flow message sending
Delays in lists and segments loading, as well as list imports
Delays in outbound events to integrations
Degraded ability to schedule campaigns

Our engineering team is actively working to mitigate the issue. We will provide more updates as we have them.
Posted Apr 11, 2023 - 14:40 EDT
This incident affected: Klaviyo App (Klaviyo App), Email Sending (Campaign Email Sending, Flow Email Sending), SMS Sending (SMS Sending - Toll Free Number SMS, SMS Sending - Toll Free Number MMS, SMS Sending - Short Code SMS, SMS Sending - Short Code MMS, SMS Sending - Other), and Segmentation, Flow Triggering, List Subscription, Signup Forms, Unsubscribe & Preference Pages.