Delays in Flow Triggering and segmentation, Elevated API Errors and Intermittent Application Page Load Issues
Incident Report for Klaviyo
Resolved
All failed flow sends have been replayed. This incident has been resolved.
Posted Oct 16, 2020 - 14:27 EDT
Update
All event processing is now real-time. We will post another update once we confirm that all failed flow sends have been replayed.
Posted Oct 16, 2020 - 00:57 EDT
Monitoring
Error rates for all APIs have subsided, and events are now processing. Flow-triggering, segmentation and all analytics are now delayed but we are actively burning down the backlog of events, and expect to be caught up 2-3 hours. All failed flow sends during this time will be replayed. We will post another update once all delays have subsided, and we will monitor this incident until it has been resolved.
Posted Oct 15, 2020 - 16:50 EDT
Update
We are continuing to work on a fix for this issue. Certain events are not processing and this issue is now impacting flow-triggering and segmentation. We will post further updates once we have an ETA to a resolution.
Posted Oct 15, 2020 - 13:49 EDT
Identified
We have identified an issue impacting Klaviyo APIs and certain pages to load across the Klaviyo application. Beginning at 12:02PM Eastern Time on October 15, users may see an error returned when trying to use subscription, list and profile APIs. Additionally, users will see pages time out within Klaviyo. We are investigating this issue and will provide updates here.
Posted Oct 15, 2020 - 12:32 EDT
This incident affected: Klaviyo App (Klaviyo App) and Klaviyo API, Analytics, Segmentation, Flow Triggering.